summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamian Lee2017-08-18 08:33:48 (GMT)
committerDamian Lee2017-08-18 08:35:00 (GMT)
commitc7531d24597d08680dc19e0189934250d251792c (patch)
tree3b652a96da3d246f269c06a89338388901d2e959
parentcd53ea6efe8306419e6052269b5899b07214f144 (diff)
Issue #2903077 by damiankloip, npcoder: Undefined index 'description' when module installed without memcache available
-rw-r--r--memcache.install8
1 files changed, 4 insertions, 4 deletions
diff --git a/memcache.install b/memcache.install
index 99ce619..9c2f800 100644
--- a/memcache.install
+++ b/memcache.install
@@ -10,10 +10,12 @@ function memcache_requirements($phase) {
$memcached = extension_loaded('memcached');
if ($phase == 'install' || $phase == 'runtime') {
+ $requirements['memcache_extension_version']['title'] = t('Memcache version');
+
if (!$memcache && !$memcached) {
$requirements['memcache_extension']['severity'] = REQUIREMENT_ERROR;
- $requirements['memcache_extension']['title'] = t('Extensions not available');
- $requirements['memcache_extension']['value'] = t('Either the <a href="http://php.net/manual/en/book.memcache.php">memcache</a> or <a href="http://php.net/manual/en/book.memcached.php">memcached</a> extensions must be installed in order to use memcache integration.');
+ $requirements['memcache_extension']['value'] = t('Extensions not available');
+ $requirements['memcache_extension']['description'] = t('Either the <a href="http://php.net/manual/en/book.memcache.php">memcache</a> or <a href="http://php.net/manual/en/book.memcached.php">memcached</a> extensions must be installed in order to use memcache integration.');
}
}
@@ -21,12 +23,10 @@ function memcache_requirements($phase) {
if ($memcache) {
// @todo: consider adding minimum version requirement for extensions.
$requirements['memcache_extension_version']['severity'] = REQUIREMENT_OK;
- $requirements['memcache_extension_version']['title'] = t('Memcache version');
$requirements['memcache_extension_version']['value'] = phpversion('memcache');
}
if ($memcached) {
$requirements['memcached_extension_version']['severity'] = REQUIREMENT_OK;
- $requirements['memcached_extension_version']['title'] = t('Memcached version');
$requirements['memcached_extension_version']['value'] = phpversion('memcached');
}
}