summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Carleton-Barnes2013-01-24 21:53:14 (GMT)
committer Gabriel Carleton-Barnes2013-01-24 21:53:14 (GMT)
commitfd4feb36a2183fade340fd45cbcf8cf78d462f3d (patch)
treef4610383a8dbb9dd397ccbd6951b36e2b95f7888
parent713072f3523b28e4821dec9e04c0e461db93c46d (diff)
more clarity in README and setting new requirements tests to run on update rather than install.
-rw-r--r--README.txt5
-rw-r--r--mailchimp.install2
2 files changed, 4 insertions, 3 deletions
diff --git a/README.txt b/README.txt
index 71eb3c6..f21a41d 100644
--- a/README.txt
+++ b/README.txt
@@ -29,12 +29,13 @@ mailchimp.module. See their respective README's for more details.
mailchimp_list module.
* For versions 7.x-2.8 and greater, the MCAPI library must be downloaded into
your libraries folder. It's available at http://apidocs.mailchimp.com/api/downloads/mailchimp-api-class.zip
- or by using the included example make file. Proper libraries structure:
+ or by using the included example drush make file. Proper libraries structure:
- libraries
- mailchimp
- MCAPI.class.php
- README
- The only required files are MCAPI.class.php and README.
+ The only required files are MCAPI.class.php and README. (You can delete the 'examples' folder with impunity)
+
## Configuration
1. Direct your browser to http://example.com/admin/config/services/mailchimp
diff --git a/mailchimp.install b/mailchimp.install
index 24c0372..f561380 100644
--- a/mailchimp.install
+++ b/mailchimp.install
@@ -46,7 +46,7 @@ function mailchimp_requirements($phase) {
);
}
}
- if ($phase == 'install') {
+ if ($phase == 'update') {
$path = drupal_get_path('module', libraries) . '/libraries.info';
$info = drupal_parse_info_file($path);
if (version_compare($info['version'], '7.x-2.0', '<')) {