summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel Catchpole2017-03-24 11:25:07 (GMT)
committerNathaniel Catchpole2017-03-24 11:25:07 (GMT)
commit35f4c06d917cbb40dceb72551787adc42ba15984 (patch)
tree8fe1894104e0793c1dd008b4a4fd57880b84151f
parent5eaf70595f5f8269da52b953a67fc8f674f61ecb (diff)
Issue #2863411 by alexpott: Adding symfony/dom-crawler with a version limit like ">=2.8.13 <3.0" is problematic
-rw-r--r--composer.lock112
-rw-r--r--core/composer.json1
2 files changed, 56 insertions, 57 deletions
diff --git a/composer.lock b/composer.lock
index d6f175f..87ce3ab 100644
--- a/composer.lock
+++ b/composer.lock
@@ -1474,62 +1474,6 @@
"time": "2017-02-28T12:31:05+00:00"
},
{
- "name": "symfony/dom-crawler",
- "version": "v2.8.18",
- "source": {
- "type": "git",
- "url": "https://github.com/symfony/dom-crawler.git",
- "reference": "24b1a3ffa5b64e4f8b1c5f2cdffd16368640704a"
- },
- "dist": {
- "type": "zip",
- "url": "https://api.github.com/repos/symfony/dom-crawler/zipball/24b1a3ffa5b64e4f8b1c5f2cdffd16368640704a",
- "reference": "24b1a3ffa5b64e4f8b1c5f2cdffd16368640704a",
- "shasum": ""
- },
- "require": {
- "php": ">=5.3.9",
- "symfony/polyfill-mbstring": "~1.0"
- },
- "require-dev": {
- "symfony/css-selector": "~2.8|~3.0.0"
- },
- "suggest": {
- "symfony/css-selector": ""
- },
- "type": "library",
- "extra": {
- "branch-alias": {
- "dev-master": "2.8-dev"
- }
- },
- "autoload": {
- "psr-4": {
- "Symfony\\Component\\DomCrawler\\": ""
- },
- "exclude-from-classmap": [
- "/Tests/"
- ]
- },
- "notification-url": "https://packagist.org/downloads/",
- "license": [
- "MIT"
- ],
- "authors": [
- {
- "name": "Fabien Potencier",
- "email": "fabien@symfony.com"
- },
- {
- "name": "Symfony Community",
- "homepage": "https://symfony.com/contributors"
- }
- ],
- "description": "Symfony DomCrawler Component",
- "homepage": "https://symfony.com",
- "time": "2017-02-21T08:33:48+00:00"
- },
- {
"name": "symfony/event-dispatcher",
"version": "v2.8.18",
"source": {
@@ -4326,6 +4270,62 @@
"description": "Symfony CssSelector Component",
"homepage": "https://symfony.com",
"time": "2017-02-21T08:33:48+00:00"
+ },
+ {
+ "name": "symfony/dom-crawler",
+ "version": "v2.8.18",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/symfony/dom-crawler.git",
+ "reference": "24b1a3ffa5b64e4f8b1c5f2cdffd16368640704a"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/symfony/dom-crawler/zipball/24b1a3ffa5b64e4f8b1c5f2cdffd16368640704a",
+ "reference": "24b1a3ffa5b64e4f8b1c5f2cdffd16368640704a",
+ "shasum": ""
+ },
+ "require": {
+ "php": ">=5.3.9",
+ "symfony/polyfill-mbstring": "~1.0"
+ },
+ "require-dev": {
+ "symfony/css-selector": "~2.8|~3.0.0"
+ },
+ "suggest": {
+ "symfony/css-selector": ""
+ },
+ "type": "library",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8-dev"
+ }
+ },
+ "autoload": {
+ "psr-4": {
+ "Symfony\\Component\\DomCrawler\\": ""
+ },
+ "exclude-from-classmap": [
+ "/Tests/"
+ ]
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Fabien Potencier",
+ "email": "fabien@symfony.com"
+ },
+ {
+ "name": "Symfony Community",
+ "homepage": "https://symfony.com/contributors"
+ }
+ ],
+ "description": "Symfony DomCrawler Component",
+ "homepage": "https://symfony.com",
+ "time": "2017-02-21T08:33:48+00:00"
}
],
"aliases": [],
diff --git a/core/composer.json b/core/composer.json
index c77bc30..85b5bc3 100644
--- a/core/composer.json
+++ b/core/composer.json
@@ -8,7 +8,6 @@
"symfony/class-loader": "~2.8",
"symfony/console": "~2.8",
"symfony/dependency-injection": "~2.8",
- "symfony/dom-crawler": ">=2.8.13 <3.0",
"symfony/event-dispatcher": "~2.8",
"symfony/http-foundation": "~2.8",
"symfony/http-kernel": "~2.8",